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1 Introduction 

To enhance the security of MTNL Broadband network and make it SPAM free, MTNL is blocking port 25 for all its broadband
clients.  This guide gives full  details  on the blockage. While we do not  expect  most broadband users to be affected by this
change, this guide presents some short term alternatives for those affected.

If you are one of the users affected by this change, you will need to make some configuration changes. This document gives
details on which MTNL Broadband users need to change configuration and how to change them.

1.1 Why 
MTNL,  Mumbai  is  one of  India's  largest  Broadband providers  with  more  than 6  lakh  clients.  Due to  its  large  size,  there  is
always  a  certain  percentage  of  PC's/users  who  connect  to  MTNL  network  and  misuse  by  sending  SPAM.  Though  the
percentage of such users is small, these users send large volume of SPAM emails and affect the service for genuine users.

There  are  also  many  PC's  which  connect  to  MTNL  broadband  and  which  do  not  have  adequate,  up-to-date  security
measures like Anti Virus. Due to this, these PC's get easily hacked and zombie/trojan malware installed. These malware are
installed without the knowledge of Broadband user. Once installed, these malware sends huge amount of SPAM through the
end user's broadband line.

A schematic of the scenario is given below

Due to this, the end user's line becomes slow and data usage unnecessarily increases.

1.2 Poor Reputation 
As  the  amount  of  SPAM  thus  sent  out  increases,  MTNL  network  reputation  takes  a  hit.  In  a  recent  check  in  a  blacklist
database  (check  done  on  8-7-2016),  we  find  that  MTNL is  in  the  top  10  in  the  blacklist.  Screenshot  of  the  same is  given
below
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Once  a  network  reputation  is  poor,  all  its  customers  (including  those  who  have  secured  PC's)  take  a  hit.  This  affects  all
broadband clients of MTNL.

1.3 Solution 
This problem is not specific to MTNL. All reputed ISP's in the world face this issue. The standard solution for this is to block
port 25 for broadband clients. This port is reserved for MTA (Mail Transfer Agents) to exchange emails. A normal broadband
user does not need to use this port. The table below gives some of the common things done by a broadband client and what
ports is being used

Action Used port(s)

Browsing 80/443

Going to facebook/twitter 80/443

Sending emails using Gmail / Yahoo / Webmail 80 / 443

Sending email using Outlook / Thunderbird 465 / 110 / 143 / 993 / 995 / 587

As one can see, port 25 is not needed for above purpose. To send SPAM, any malware exclusively uses port 25. Therefore
by blocking port 25

• Malware is made ineffective.

• Hackers have no incentive to install malware.

Some of the other large ISP's who have followed this method are:

• AT&T
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• AOL

1.4 Which users are affected? 
As we saw in the previous section, normal users are not affected by this blockage. However, there may be some users who
are using port 25 to send emails from Outlook / Thunderbird. These users need to make some changes.

Once the blockage is in place, these users will not be able to send out emails. Then the following should be done

1. Contact the Email Server administrator for your email domain.

2. Get details of an alternative port (say 465 / 587) to send out emails.

3. Incorporate the same into your Email client (Outlook / Thunderbird).

4. Now the emails should go out fine.

If the above process takes time, you can make use of MTNL relay email account to send out emails. If you do want to use
MTNL relay accounts to send emails, proceed to the next section.
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2 Affected MTNL Users 

MTNL provides an email account to all its Broadband users. This account can be used to send out emails. You can use the
tables below to find out if you will need to reconfigure your Email clients

1. Users who will need to reconfigure their Email clients

Description Yes/No

Are you using any of following client to send emails?

1. Microsoft Outlook

2. Microsoft Windows Live / Outlook Express

3. Thunderbird

4. SMTP Email client

and

Does your Outgoing email port configured as 25 in your Email client configuration?

When you send emails, does the email remain in your Outbox and not go out?

If you answered Yes to any of the above, you will need to change the configuration in your Email client. You may proceed to
the next sections on how to do the same.

2. Users who do not need to change their Configuration

Description Yes/No

Do you send emails only using Internet browser like the following:

1. Internet Explorer

2. Google Chrome

3. Mozilla Firefox

4. Apple Safari

Do you use your MTNL connection only for browsing?
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You only use a Free Email ID like

• @yahoo.com

• @gmail.com

• @rediffmail.com

• @sify.com

• @mtnl.net.in

• @live.com

• @hotmail.com

and you send emails only using a browser.

If you answered Yes to any of the above, this change will not affect you and you do not need to change any configuration.
The move by MTNL will not affect you.
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3 Pre-requisites - Dynamic IP 

Prior to changing the configuration, you will  need to obtain certain information from MTNL if  your plan involves dynamic IP
addresses. All MTNL connectivity is classified into two different categories. Those users who get Dynamic IP addresses and
those users who get Static IP addresses.

If your connection has a Static IP address, you do not need to do anything further and you can proceed to making changes
in actual configuration.

If  your  connection  has  a  Dynamic  IP  address,  or  if  you  are  not  sure  what  category  you  belong  to,  please  follow  the
instructions below.

Now you are ready to configure the Email clients.

3.1 Get a Free MTNL Email Id 

1. If you are a Broadband customer, register for the Free email account provided by MTNL. You will get a @mtnl.net.in 
Email address.

2. To create the Free email account, please send mail to register@mtnl.net.in with following details

• Broadband Landline Number

• CA Number

• Desired Email address

• Mobile Number

• Alternate Email address

3. Once the email address is created, you will be notified over the alternate Email address.

4. Once you have the Email address, confirm that you are able to login by logging into http://mail.mtnl.net.in

5. Proceed to the next section

3.2 Add Aliases 
If you are using any other domain (Corporate or Free email addresses) to send out emails, you will need to add that Email
address as a sender Alias. If you are uing @mtnl.net.in to send out emails, you may skip this section.
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1. Login to http://mail.mtnl.net.in

2. Click on Email tab as indicated by a Red oval in the below figure

3. That will bring up the following window. Click on Administration menu as indicated by a Red oval in figure below.

4. That will bring up the following menu. Choose Accounts (as indicated by Red Oval)

5. That will bring up the following dialog. Double click on your account (as indicated by Red oval).

6. That will bring up the following dialog. Click on Manage sender aliases as indicated by Red oval.
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7. That will bring up the following dialog. In that click on Add button as indicated by Red oval.

8. That will bring up the following dialog.
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9. In the above dialog, enter

• Sender full name in Name field (indicated by Red oval).

• Email address you are using to send email from in Email field (indicated by Green oval).

• Click on OK button (indicated by Blue Oval).

10. Click on OK / Close on all the dialogs and Logout of Webmail.

11. To confirm that you are the owner of the email ID that is added, Rainmail Server will ask you to confirm by clicking on a 
link in the email sent to the added Email ID.

12. Open your email client / Webmail to access your email. You should see an email like below. Click on the confirmation 
link as indicated by Red oval.

13. That will bring you to the following page

14. Now you are ready to use MTNL as a relay email server. You can add up to two Email addresses as Alias per MTNL 
email ID.

15. Proceed to the next sections for configuration changes.
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4 Configuration - Concepts 

In this document, we will give instructions for some popular email clients. We will also explain the configuration conceptually
so that MTNL users can configure other email clients. The concept is to send emails through the MTNL Anti SPAM server.
For sending the same, following details should be used

1. For users with Static IP connectivity - with IP based mail relay

Parameter Value

Outgoing SMTP Server / Relay Server smtp.mtnl.net.in

Outgoing SMTP Port Number 587

Use SSL No

Outgoing Server requires authentication No

2. For users without Static IP connectivity - who have alias based email relay

Parameter Value

Outgoing SMTP Server / Relay server smtp.mtnl.net.in

Outgoing SMTP Port Number 587

Use SSL No

Outgoing Server requires SMTP Authentication Yes

SMTP Authentication user name Email ID obtained from MTNL e.g., user@mtnl.net.in

SMTP Authentication password Password for Email ID obtained from MTNL
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5 Configuration - Microsoft Outlook - No 
Static IP 

If you are using MTNL connection without Static IP (using alias based email relay) and Microsoft Outlook to send out emails,
you will need to make the following changes to ensure that your emails go out properly. The following instructions will guide
you on what is to be done. If you have configured multiple email accounts, you will need to do the below for each account.

1. Open up Microsoft Outlook and click on File menu. That will bring up the following screen.

2. Click on Account Settings and that will bring up the following dialog
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3. In the above dialog, double click on he account (as indicated by Red Oval). That will bring up the following dialog.

4. In the above dialog, in the Outgoing mail server (SMTP) edit box (indicated by Red Oval in above page), enter value as 
smtp.mtnl.net.in
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4. Click on the More Settings button (indicated by Red Oval above). That will bring up the following dialog.

5. In he above dialog, click on Outgoing Server tab. That will bring up the following dialog.
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6. In the above dialog

1. Check the My outgoing server (SMTP) requires authentication box (as indicated by Red Oval)

2. Click on Log on using (indicated by Green Oval)

3. Enter your @mtnl.net.in Email address in User Name edit field.

4. Enter the above account's password in Password edit field (indicated by Blue Oval)

5. Check the Remember Password box (as indicated by Yellow Oval).

7. In the dialog above, click on Advanced tab (indicated by Red Oval). That will bring up following dialog.
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8. In the above dialog in the edit field for Outgoing server (SMTP) (indicated by Red Oval), enter 587.

9. Click on OK and close all the dialogs.

10. Now you are all set to send out emails using MTNL network.
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6 Configuration - Microsoft Outlook - 
Static IP 

If you are using MTNL connection with Static IP (using IP based email relay) and Microsoft Outlook to send out emails, you
will need to make the following changes to ensure that your emails go out properly. The following instructions will guide you
on what is to be done. If you have configured multiple email accounts, you will need to do the below for each account.

1. Open up Microsoft Outlook and click on File menu. That will bring up the following screen.

2. Click on Account Settings and that will bring up the following dialog
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3. In the above dialog, double click on the account (as indicated by Red Oval). That will bring up the following dialog.

4. In the above dialog, in the Outgoing mail server (SMTP) edit box (indicated by Red Oval in above page), enter value as 
smtp.mtnl.net.in
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4. Click on the More Settings button (indicated by Red Oval above). That will bring up the following dialog.

5. In the above dialog, click on Outgoing Server tab. That will bring up the following dialog.
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6. In the above dialog

1. Uncheck the My outgoing server (SMTP) requires authentication box (as indicated by Red Oval)

7. In the dialog above, click on Advanced tab (indicated by Red Oval). That will bring up following dialog.
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8. In the above dialog in the edit field for Outgoing server (SMTP) (indicated by Red Oval), enter 587.

9. Click on OK and close all the dialogs.

10. Now you are all set to send out emails using MTNL network.
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7 Configuration - Microsoft Live Mail - 
No Static IP 

If  you  are  using  MTNL  connection  without  Static  IP  (using  alias  based  email  relay)  and  Microsoft  Live  Mail  to  send  out
emails, you will need to make the following changes to ensure that your emails go out properly. The following instructions will
guide  you  on  what  is  to  be  done.  If  you  have  configured  multiple  email  accounts,  you  will  need  to  do  the  below for  each
account.

1. Open up Microsoft Live Mail and right click on configured account (as indicated in Red).

2. That will bring up the following menu.

3. Click on Properties (as indicated by Red Oval above) and that will bring up the following dialog
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3. In the above dialog, click on Servers tab (indicated by Red Oval). That will bring up the following dialog.

4. In the above dialog,

1. In the Outgoing mail server (SMTP) edit box (indicated by Red Oval in above page), enter value as smtp.mtnl.net.in

2. Check My server requires authentication box (indicated by Blue Oval).

3. Click on Settings button (indicated by Green Oval)

4. That will bring up following dialog.
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4. In the above dialog:

1. Click on Log on using (indicated by Red Oval)

2. Enter your @mtnl.net.in Email address in Account Name edit field (indicated by Blue Oval)

3. Enter the above account's password in Password edit field (indicated by Green Oval)

4. Check the Remember Password box (as indicated by Yellow Oval).

5. Click on OK to close the dialog

7. In the dialog above, click on Advanced tab (indicated by Red Oval). That will bring up following dialog.
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8. In the above dialog in the edit field for Outgoing mail (SMTP) (indicated by Red Oval), enter 587.

9. Click on OK and close all the dialogs.

10. Now you are all set to send out emails using MTNL network.
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8 Configuration - Microsoft Live Mail - 
Static IP 

If you are using MTNL connection with Static IP (using IP based email relay) and Microsoft Live Mail to send out emails, you
will need to make the following changes to ensure that your emails go out properly. The following instructions will guide you
on what is to be done. If you have configured multiple email accounts, you will need to do the below for each account.

1. Open up Microsoft Live Mail and right click on configured account (as indicated in Red).

2. That will bring up the following menu.

3. Click on Properties (as indicated by Red Oval above) and that will bring up the following dialog
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3. In the above dialog, click on Servers tab (indicated by Red Oval). That will bring up the following dialog.

4. In the above dialog,

1. In the Outgoing mail server (SMTP) edit box (indicated by Red Oval in above page), enter value as smtp.mtnl.net.in

2. Uncheck My server requires authentication box (indicated by Blue Oval).
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7. In the dialog above, click on Advanced tab (indicated by Red Oval). That will bring up following dialog.

8. In the above dialog in the edit field for Outgoing mail (SMTP) (indicated by Red Oval), enter 587.

9. Click on OK and close all the dialogs.

10. Now you are all set to send out emails using MTNL network.
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9 Configuration - Thunderbird - No 
Static IP 

If you are using MTNL connection without Static IP (using alias based email relay) and Thunderbird to send out emails, you
will need to make the following changes to ensure that your emails go out properly. The following instructions will guide you
on what is to be done. If you have configured multiple email accounts, you will need to do the below for each account.

1. Open up Thunderbird, click on Tools -> Account Settings menu. That will bring up the following dialog.

2. Click on Outgoing Server (SMTP) (indicated by Red Oval). That will bring up the following dialog.
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3. Click on Edit (as indicated by Red Oval above) and that will bring up the following dialog

4. In the above dialog,

1. In the Server Name edit box (indicated by Red Oval in above page), enter value as smtp.mtnl.net.in

2. In Port edit box (indicated by Blue Oval), enter value as 587.

3. Enter your @mtnl.net.in Email address in User Name edit field (indicated by Green Oval)

5. Click on OK and close all the dialogs.

6. Now you are all set to send out emails using MTNL network.
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10 Configuration - Thunderbird - Static 
IP 

If  you are using MTNL connection with Static IP (using IP based email  relay) and Thunderbird to send out emails, you will
need to make the following changes to ensure that your emails go out properly. The following instructions will guide you on
what is to be done. If you have configured multiple email accounts, you will need to do the below for each account.

1. Open up Thunderbird, click on Tools -> Account Settings menu. That will bring up the following dialog.

2. Click on Outgoing Server (SMTP) (indicated by Red Oval). That will bring up the following dialog.
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3. Click on Edit (as indicated by Red Oval above) and that will bring up the following dialog

4. In the above dialog,

1. In the Server Name edit box (indicated by Red Oval in above page), enter value as smtp.mtnl.net.in

2. In Port edit box (indicated by Blue Oval), enter value as 587.

3. Select No authentication in Authentication method list box (indicated by Green Oval)

5. Click on OK and close all the dialogs.

6. Now you are all set to send out emails using MTNL network.
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11 Configuration - Lotus Notes Client - 
No Static IP 

If  you  are  using  MTNL  connection  without  Static  IP  (using  alias  based  email  relay)  and  Lotus  Notes  Client  to  send  out
emails, you will need to make the following changes to ensure that your emails go out properly. The following instructions will
guide  you  on  what  is  to  be  done.  If  you  have  configured  multiple  email  accounts,  you  will  need  to  do  the  below for  each
account.

1. Open up Lotus Notes Client, click on File -> Preferences menu. That will bring up the following dialog.

2. In the above dialog

1. Click on Accounts (indicated by Red Oval) and select the pane.

2. Click on Outgoing Internet mail (indicated by Blue Oval) item.

3. Click on Edit Account (indicated by Green Oval) button.

4. That will bring up the following dialog
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3. In the above dialog,

1. In the Server edit field (indicated by Red Oval), enter smtp.mtnl.net.in

2. In the Name edit field (indicated by Blue Oval), enter your full MTNL email address.

3. In the Password edit field (indicated by Green Oval), enter MTNL email password.

4. Click on Advanced properties (indicated by Black Oval).

5. In the Port number edit field (indicated by Yellow Oval), enter 587.

4. Click on OK and close all the dialogs.

5. Now you are all set to send out emails using MTNL network.
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12 Configuration - Lotus Notes Client - 
Static IP 

If you are using MTNL connection with Static IP (using IP based email relay) and Lotus Notes Client to send out emails, you
will need to make the following changes to ensure that your emails go out properly. The following instructions will guide you
on what is to be done. If you have configured multiple email accounts, you will need to do the below for each account.

1. Open up Lotus Notes Client, click on File -> Preferences menu. That will bring up the following dialog.

2. In the above dialog

1. Click on Accounts (indicated by Red Oval) and select the pane.

2. Click on Outgoing Internet mail (indicated by Blue Oval) item.

3. Click on Edit Account (indicated by Green Oval) button.

4. That will bring up the following dialog
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3. In the above dialog,

1. In the Server edit field (indicated by Red Oval), enter smtp.mtnl.net.in

2. Click on Advanced properties (indicated by Green Oval).

3. In the Port number edit field (indicated by Blue Oval), enter 587.

4. Click on OK and close all the dialogs.

5. Now you are all set to send out emails using MTNL network.
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13 Configuration - Email Servers - Static 
IP 

With a static IP from MTNL, it  is possible to run email  servers. Since port 25 is blocked, MTNL clients will  have to change
their  email  server  configuration  so  that  emails  are  relayed out  through smtp.mtnl.net.in  (MTNL Anti  SPAM server),  using
port 587. In this section, we will present the configuration to be done for popular Email servers.

Email Server Instructions

Sendmail 1. Edit sendmail.mc file (usually present in /etc/mail/sendmail.mc)

2. Add the following lines to the file

define(`SMART_HOST',`relay:smtp.mtnl.net.in')dnl

define(`RELAY_MAILER',`esmtp')dnl

define(`RELAY_MAILER_ARGS', `TPC $h 587')dnl

3. make -C /etc/mail

4. Restart sendmail

Postfix 1. Add the following to main.cf (usually present in/etc/postfix/main.cf)

relayhost = smtp.mtnl.net.in:587

2. Reload postfix

Qmail 1. Add the following line to smtproutes (usually in /var/qmail/control/smtproutes)

:smtp.mtnl.net.in:587

2. Restart Qmail

Lotus Domino Server See this URL: 
http://www-12.lotus.com/ldd/doc/domino_notes/Rnext/help6_admin.nsf/0/9285c3fdb9624987
85256c1d00395482?OpenDocument
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Microsoft Exchange Server 1. Open MMC

2. Go to Servers -> Protocols

3. Select Default SMTP Virtual Server Properties

4. Go to Delivery tab

5. Click on Advanced Button

6. Enter smtp.mtnl.net.in in Smart Host edit box.

7. Close MMC

8. Open Exchange Management Shell using

Start  -> Programs -> Microsoft Exchange Server -> Exchange Management Shell

9. By Default the "Send Connector" is called "All Outbound" unless you have changed it or 
added additional connectors. To determine this you can type the following at the 
Exchange Management Shell

Get-SendConnector

10. Type the following

Set-SendConnector -Identity "All Outbound" -port 587

or the following if your connector is called something else from the default

Set-SendConnector -Identity "SENDCONNECTORNAME" -port 587

11. Restart SMTP Service
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